KotyaFila
10.11.2021 12:24

Составить программу, которая заполняет моссив a(n) в порядке 1 2 3 1 2 3

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
агамтасия
04.10.2020 09:47
// PascalABC.NET 3.2, сборка 1325 от 19.10.2016
begin
  var n:=ReadInteger('n=');
  SeqGen(n,1,x->x mod 3 +1).Println
end.

Пример
n= 15
1 2 3 1 2 3 1 2 3 1 2 3 1 2 3
0,0(0 оценок)
Ответ:
nikola58
04.10.2020 09:47
Program massiv123; 
const n=30; 
Type massiv=array[1..n] of integer; 
var i:integer; a:massiv; 
begin 
for i:=1 to n do 
if i mod 3=0 then a[i]:=3 
             else a[i]:=1; 
for i:=1 to n do 
if a[i]=3 then a[i-1]:=2; 
write('Массив: '); 
for i:=1 to n-1 do 
write(a[i],','); 
write(a[n],';'); 
end.

Если надо изменить кол-во цифр, то изменяйте в const n=кол-во;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота