Составить программу для вычисления среднеарифметического n произвольных чисел. обозначения: s-сумма всех чисел; sr-среднеарифметическое n чисел; a-значение i-го числа; n-количество чисел.
PROGRAM PR17; VAR I,N:INTEGER; S,SR,A:REAL: BEGIN WRITE(‘ Введите N’); READLN(N); S:=0; FOR I:=1 TO N DO BEGIN WRITE(‘ Введите ‘,I,’ число’); READLN(A); S:=S+A: END; SR:=S/N; 43 WRITELN(‘ответ: SR = ’,SR:8:3); END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку