mawa18
29.04.2020 19:56

Написать программу для решения следующей : вычислить и вывести сумму и число отрицательных элементов каждой строки матрицы а(10,10).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
тупой810
20.08.2020 06:41
Const n=10;     
 m=10;
var A: array [1..n,1..m] of integer;
s, k, i, j: integer;
begin
randomize;
for i:= 1 to n do
begin
for j:= 1 to m do
begin
A[i,j]:= -100 + random (100);
write (A[i,j]: 5);
end;
writeln;
end;
for i:= 1 to n do
begin 
 s:=0;
  k:=0; 
for j:= 1 to m do   
 if A[i,j] < 0 then
     begin
        s:=s+A[i,j];
        k:=k+1;
     end; 
 writeln('в строке', i, '  отрицательных элементов' , k, '   s  отрицат. =  ', s);
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота