влада409
25.04.2022 00:27

Составить программный код на языке pascalabc, вот по этй . 1) на вход программы подается 366 строк, которые содержат информацию о среднесуточной температуре всех дней 2008 года. формат каждой из строк следующий: сначала записана дата в виде dd.mm (на запись номера дня и номера месяца в числовом формате отводится строго два символа, день от месяца отделен точкой), затем через пробел записано значение температуры — число со знаком плюс или минус, с точностью до 1 цифры после десятичной точки. данная информация отсортирована по значению температуры, то есть хронологический порядок нарушен. требуется написать программу на языке паскаль или бейсик, которая будет выводить на экран информацию о месяце (месяцах), среднемесячная температура у которого (которых) наименее отклоняется от среднегодовой. в первой строке вывести среднегодовую температуру. найденные значения для каждого из месяцев следует выводить в отдельной строке в виде: номер месяца, значение среднемесячной температуры, отклонение от среднегодовой температуры.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
6789234158333
22.05.2020 12:49

В одну папку со своими страницами поместите файлы glavnaya.txt и wallpaper.jpg (фон).

При этом файл с таблицей переименуйте на 'таблиця.html', файл с планами - на 'плани.html', а файл с определениями - на 'означення.html'.

И смените расширение glavnaya.txt на glavnaya.html.

<!DOCTYPE html>

<html>

<head>

 <meta charset="utf-8">

 <title>Головна сторінка</title>

 <style>

  body {

   /*устанавливаем фон страницы*/

   background-image: url('wallpaper.jpg');

   background-size: cover;

   /*устанавливаем шрифт*/

   font-family: Arial;

  }

  li {

   /*увеличиваем размер шрифта*/

   font-size: 25px;

  }

 </style>

</head>

<body>

 <h1 align="center">Усі сторінки. Оксенчук Саша</h1>

 <ul>

  <li>Моя таблиця розміщена <a href="таблиця.html">тут</a>.</li>

  <li>Мої плани розміщені <a href="плани.html">тут</a>.</li>

  <li>Означення розміщені <a href="означення.html">тут</a>.</li>

 </ul>

</body>

</html>


Соедините все веб-страницы с гиперссылок в одну главную веб-страницу, с названием glavnaya.html. Уст
Соедините все веб-страницы с гиперссылок в одну главную веб-страницу, с названием glavnaya.html. Уст
0,0(0 оценок)
Ответ:
llllsaaaaaa
28.12.2021 11:20

Если текущее число равно n, то последняя цифра в нем - остаток от деления на 10. В цикле проверяем, если последняя цифра числа 8, то увеличиваем переменную-счетчик восьмерок. После этого отбрасываем последнюю цифру. В конце полученное количество умножаем на 1000 и выводим на экран.

Код (C++):

#include <iostream>

int main() {

 int n, count = 0;

 std::cin >> n;

 while (n > 0) {

     if (n % 10 == 8) count++;

     n /= 10;

 }

 std::cout << count * 1000;

}

Пример ввода:

88880

Пример вывода:

4000

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота