nastya20174
20.02.2022 08:05

Составить программу на паскале. имеется целочисленный массив, состоящий из 10 элем-тов. а) найти сумму первых 5 элементов; б) найти сумму чётных элементов стоящих на чётных позициях.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
asus10memopadp06j6e
20.08.2020 01:52
В цикле от 1 до 10 вводим i-тый элемент массива. Сразу в этом же цикле проверяем два условия: 1) если i < 6 то прибавляем этот элемент к сумме1 2) если i чётное и элемент чётный прибавляем его к сумме2. С телефона не выделяются абзацы, поэтому сори за вид. 
Program zzz; Var s1, s2: integer; x: boolean;Var i: byte; Var M: array[1..10] of integer; Begin s1:=0; s2:=0; For i:=1 to 10 do begin Writeln ('введите ',i,'-е число массива'); Readln (M[i]); If i<=5 then s1:=s1+M[i]; if ((i mod 2)=0) and ((M[i] mod 2)=0)Then s2:=s2+M[i]; End; Writeln ('Сумма первых 5 элементов = ',s1);Writeln ('Сумма чётных элементов стоящих на чётных позициях = ',s2);End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота