розасит2006
01.04.2022 11:09

Дан одномерный вещественный массив из n чисел. написать программу нахождения суммы элементов массива стоящих на нечетных позициях (индекс). блок схема не нужна только программа 10

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vagiz9779
04.10.2020 05:21
Var
s:real;
n,i:integer;
a:array[1..1000] of real;

begin
write('Введите кол-во элементов: '); readln(n);
writeln('Введите элементы: ');
for i:=1 to n do 
read(a[i]);
s:=0;
for i:=1 to n do
if odd(i) then s:=s+a[i]; 
writeln('Сумма: ',s);

end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота