Temka333333
27.08.2020 05:47

Написать программу на pascal'e: массив a содержит натуральные числа. создать массив b, который содержит только простые числа из a в порядке возрастания. массив b сортировать методом простого выбора. вывести на печать массив b или сообщить, что он пуст.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
peindragneel11
29.09.2020 15:54

ДЗ для ВЕРЫ ВИКТОРОВНЫ:

Объяснение:

Var I, N, m: integer;

{Выводит таблицу квадратов до N числа}

Begin

Readln(N); //Что вводим в этой строке и зачем? Как можно подсказать пользователю, что ввести?  

{Вводим до какого числа нам нужно получить квадрат; Подсказать можно через WRITELN}

Writeln('Таблица квадратов чисел от 1 до N'); //Сколько раз выполняется этот оператор?

{Один раз}

For i:=1 to N do //Сколько раз выполнится цикл?

{N раз}

Begin //Зачем снова писать операторные скобки?

{Затем, что это цикл, который всегда обособляется и отделяет от остальных операторов}

m:=i*I;

Writeln(I,' ',m); //Как по-другому оставить пробелы между столбиками?

{Можно сделать так    -     Writeln(I:3,m:16);}

End;

End.

0,0(0 оценок)
Ответ:
vikulovatanya
22.06.2022 23:54

Вот точно таких же вопросов на этом сайте несколько сотен, если не тысяч

Учитываем, сколько занимает памяти каждый символ. Для этого надо знать кодировку. Если кодировка не указана, то по умолчанию считаем, что один символ занимаем один байт - восемь бит.

Перемножаем все три числа 100 страниц * 35 строк * 50 символов в строке = 175000 символов в книге, или 175000 байт в нашем случае.

Каждый байт содержит 8 бит, так что 175000 байт * 8 бит в байте = 1400000 бит

Кб содержит 1024 байта, 175000 байт / 1024 ≈ 170.9 КБайт

Мб содержит 1024 Кбайта, 170.9 Кбайт / 1024 ≈ 0.167 МБайт

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота