olya2005i
05.06.2021 11:22

Написать программу си++ задан массив целых чисел вычислить сумму отрицательных элементов этого массива и определить их количество

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nastya2719
09.08.2020 07:24
#include <iostream>
using namespace std;
int main()
{
int n, sum,howmuch;
sum = howmuch = 0;
cout << "Введите количество элементов массива" << endl;
cin >> n;
int a[n];
for(int i =0; i < n; i++){
cout << "Заполните массив" << endl;
cin >> a[i];
}

for(int i = 0; i < n; i++){
if (a[i] < 0)
{
howmuch++;
sum += a[i];
}
}
cout << "Сумма отрицательных элементов массива:" << sum << endl;
cout <<"Количество отрицательных объектов массива" << howmuch << endl;
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота