380674944183
10.03.2020 17:51

опишите этот код. прям пошагово объясните. pascal abc
вот : написать программу, в которой пользователь вводит 5 чисел и нужно вывести максимальное число и минимальное. и поменять их местами.
например:
6
7
8
9
10
макс.- 10
мин.- 6
10
7
8
9
6

код:
program d;
var min,max,a : integer;
mas: array[1..5] of integer;
begin
for a: =1 to 5 do
begin
readln(mas[a]);
if mas[a]< =mas[min] then min: =a;
if mas[a]> =mas[max] then max: =a;
end;
writeln;
writeln (mas[max]);
for a: =1 to 5 do
if (a< > min)and(a< > max) then writeln (mas[a]);
writeln(mas[min]);
end.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
PollyHyper
04.10.2020 03:47

maxN = индекс макс значения в массиве , minN - миним индекс массива

Через if мы по этапно сравниваем значения , если условия верны то , значения min/max меняется на текущее значения массива

Объяснение:

program d;

var min,max,i,minN,maxN : integer;

mas:array[0..4] of integer;

begin

for i:=0 to 4 do

begin

 readln(mas[i]);

end;

min:=mas[0];

minN:=1;

maxN:=1;

max:=mas[0];

for i:=1 to 4 do

begin

 if min<mas[i] then begin minN:=i; min:=mas[i] end;

 if max>mas[i] then begin maxN:=i; max:=mas[i] end;

end;

mas[maxN]:=min;

mas[minN]:=max;

For i:=0 to 4 do

writeln(mas[i]);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота