ДАШУНЯ1311
24.10.2022 07:02

C/c++.

найдите наименьший четный элемент массива. если такого нет, то выведите первый элемент.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
JasminNuar544
04.10.2020 03:22

#include <iostream>

using namespace std;

int main() {

int n, k=0;

cin>>n;

int arr[n];

for (int i=0; i<n; ++i) {cin>>arr[i]; if (arr[i]%2==0&&(arr[i]<arr[k]||arr[k]%2==1)) k=i;}

cout<<arr[k];

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота