Акшувел
14.05.2020 05:41

Написать программу на с++! напишите программу, которая вычисляет выражение, состоящее из трех чисел и двух знаков (допускаются знаки «+», «–», «*» и «/»). выражение вводится как символьная строка, все числа целые. операция «/» выполняется как целочисленное деление (div). пример: введите выражение: 12*3+45 ответ: 81

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nechakva86
20.03.2020 05:09

Памятник представляет собой копию клавиатуры из бетона в масштабе 30:1. Состоит из 104 клавиш, сделанных из бетона весом от 100 до 500 кг, расположенных в раскладке QWERTY. Клавиши расположены в углублениях с интервалом 15 см. Общая площадь проекта 16 × 4 м. Поверхность клавиш плоская с рельефными обозначениями алфавита и функциональных символов, размещенных в том же порядке, что и на обычной компьютерной клавиатуре.

В июле 2016 года на клавише End установлена мемориальная доска в честь Евгения Зорина

0,0(0 оценок)
Ответ:
yuniman
03.01.2022 21:17
Возьмем произвольное число n. Оно будет иметь ровно два знака в шестнадцатеричной записи тогда и только тогда, когда 15 < n < 256. Таким образом, задача сводится к нахождению количества элементов массива находящихся в промежутке (15; 256). 
Первую цифру числа в шестнадцатеричной записи можно найти как N div 16, а вторую - N mod 16
Программа на языке Pascal:

const
  N = 2017; // Количество элементов в массиве

var
  a: array[1..N] of integer;
  i, c: integer;

begin
  // Генерация массива (можно изменить на ввод с клавиатуры)
  for i := 1 to N do
    a[i] := Random(10000) + 1;
  // Подсчет количества элементов массива, удовлетворяющим 
неравенству
  c := 0;
  for i := 1 to N do
    if (a[i] > 15) and (a[i] < 256) and (a[i] div 16 > a[i] mod 16) then
      c += 1;
  write(c);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота