Nastya171167
06.12.2021 06:39

Написать программу с одномерным массивом, которое находит средне арифметическое ​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ДашаНифонтова
29.05.2020 06:15

program ;

uses crt;

var

a:array[1..100] of integer;

i:integer;

s:real;

begin

clrscr;

randomize;

for i:=1 to 100 do

  begin

  a[i] := random(100)+1;

  s:=s+a[i];

  end;

s:=s/100;

writeln(s:20:2);

end.

Объяснение:

Массив 'a' заполняется рандомными числами в цикле for, где параллельно с этим в переменную 's' добавляется значения массива с индексом 'i'. После цикла 's' делиться на 100 тем самым получая среднее арифметическое, а после результат выводится.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота