maksim15m15
19.03.2022 12:25

Написать программу, принимающую на вход два вектора (a1, a2, a3) и (b1, b2, b3) и вычисляющую объем параллелепипеда, образованного тройкой векторов a, b, [a,b]. на выходе программа должна выдавать два числа: первое - объем параллелепипеда, второе - является ли тройка векторов a, b, [a,b] компланарной. решить на c++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ruslan3252
04.10.2020 02:21
//Dev-C++ 5.11

#include <iostream>
#include <cmath>
using namespace std;

int main(void)
 {int ax,bx,abx,ay,by,aby,az,bz,abz;
 float v,amod,bmod,abmod;
 cin>>ax>>ay>>az>>bx>>by>>bz;
 abx=ay*bz-by*az;
 aby=az*bx-ax*bz;
 abz=ax*by-ay*bx;
 amod=sqrt(pow(ax,2)+pow(ay,2)+pow(az,2));
 bmod=sqrt(pow(bx,2)+pow(by,2)+pow(bz,2));
 abmod=sqrt(pow(abx,2)+pow(aby,2)+pow(abz,2));
 v=abs(ax*(by*abz-aby*bz)-ay*(bx-abz-abx*bz)+az*(bx*aby-abx*by));
 cout<<"V="<<v<<endl;
 if(v==0)
  cout<<"YES";
 else
  cout<<"NO";
 return 0;}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота