книга67
18.08.2020 01:38

Напишите программу для скретч​

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Topergggg
24.04.2021 16:09
Для перевода в двоичную систем счисления последовательно делим число на два нацело до получения в ответе нуля или единицы и выписываем остатки.
512/2=256, остаток 0
256/2=128, остаток 0
128/2=64, остаток 0
64/2=32, остаток 0
32/2=16, остаток 0
16/2=8, остаток 0
8/2=4, остаток 0
4/2=2, остаток 0
2/2=1, остаток 0
А теперь записываем частное и приписываем к нему справа в обратном порядке все остатки. Получаем 1000000000(2).
Можно было всего этого и не делать, если мы помним, что 512 - это два в ДЕВЯТОЙ степени. Тогда сразу можно написать единицу и ДЕВЯТЬ нулей.

Для перевода числа из двоичной системы в восьмеричную следует разбить в направлении справа налево двоичное число по три разряда (получая так называемые триАды). А затем каждую триаду заменить соответствующей восьмеричной цифрой. Самую левую триаду, если она неполная, дополняют слева незначащими нулями. В основе такого перевода лежит то, что восемь - это третья степень числа два.
1000000000(2)=001 000 000 000(2)=1000(8)

Для перевода числа из двоичной системы в шестнадцатиричную следует разбить в направлении справа налево двоичное число по четыре разряда (получая так называемые тетрАды). А затем каждую тетраду заменить соответствующей шестнадцатиричной цифрой. Самую левую тетраду, если она неполная, дополняют слева незначащими нулями. В основе такого перевода лежит то, что шестнадцать - это четвертая степень числа два.
1000000000(2)=0010 0000 0000(2)=200(16)
0,0(0 оценок)
Ответ:
Lakers44
18.01.2022 18:32
PascalABC.NET

1)
 const     n = 10;
 var
   a : array [1..n] of integer;
   i : integer;
 begin 
  randomize; 
   for i := 1 to n do 
    begin 
    a[i] := 22 + random(114); 
    if a[i] > 100 then 
     writeln (a[i]); 
    end;
  end.

2)
 var 
  a,n,r,i : integer; 
   begin 
 r := 1; 
 readln (a,n); 
  for i := 1 to n do 
   r := r * a;
  writeln (r);
   end.

3)

 var 
 n,i,r : integer;
    begin 
 r := 1; 
 readln (n);
   for i := 1 to n do
    r := r *i; 
 writeln (r);
  end.

4)
 var 
 i : integer;
 begin
  for i := 192 to 223 do
   write(chr(i); ,'  '); 
end.

5)
 var 
 i : integer; 
   begin  
  for i := 255 downto 240 do
   write (chr(i),' ');  
  writeln();  
  for i := 239 downto 224 do 
 write (chr(i),' ');  
  end.

7)
 var 
 i : integer; 
begin  for i := 122 downto 97
do   writeln(chr(i)); 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота