Войти
Регистрация
Спроси ai-bota
topaxx100
01.08.2020 22:20
Написать программу си++ вот условие : задан массив целых чисел. отсортировать четные элементы массива по возрастанию, а нечетные по убыванию. нужно
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
ДимаЛапа
15.02.2023 16:58
Напишите рекурсивную функцию, которая раскладывает число на простые сомножители. пример: введите натуральное число: 378 378 = 2*3*3*3*7...
polina1347
19.02.2020 05:38
Решить. ступеньки к информатики 3 класс. раздели прямоугольник на 4 части, чтобы они были одинаковой формы и содержали одинаковое количество квадратов. запиши план презентации...
аня2835
18.01.2021 10:49
Чему будет равно значение переменной c в результате выполнения фрагмента программы a: =125; b: =25; c: =12; if a div 25=0 then if a mod 12=0 then c: =b div (a mod c) else c: =a...
Алтынбек05
18.01.2021 10:49
Укажите результат выполнения программы var a,b: integer; procedure proc(var a: integer; b: integer); begin b: =4; a: =6; b: =a+b; end; begin a: =2; b: =3; proc(a,b); writeln(a,...
огпгпощо
22.03.2021 17:30
Запишите алгоритм, позволяющий определить, есть ли среди цифр заданного целого трёхзначного числа x одинаковые записи выберите самостоятельно....
Патич232
22.03.2021 17:30
Как записать число 116,725 на языке паскаль?...
Sinderella2006
22.03.2021 17:30
Есть числа x,y,z надо найти min(x,y,z)...
срочно119
22.03.2021 17:30
По экселю, ! елена билькевич знаток (403), вопрос открыт 1 минуту назад нужно построить график по данным пункта ( т. е. год, сумма улова рыбы) данные: 5 6 сумма.. 100 любые числа...
lyazkaiman0309
22.03.2021 17:30
Дано шестизначное число. переставить две средние цифры в начало числа. 123456 должно получится 341256 через паскаль...
rensatkontri
22.03.2021 17:30
Сложные высказывания,заранее . (a v b) & (a v ¬ b) ¬( ¬хv-у)...
Ответ:
jkazlova
04.10.2020 01:58
//Dev-C++ 5.11
#include <iostream>
using namespace std;
int main(void)
{const int n=6;
int arr[n],c;
for(int i=0;i<n;i++)
cin>>arr[i];
for(int i=0;i<n-1;i++)
for(int j=i+1;j<n;j++)
if(arr[i]>arr[j] && arr[i]%2==0 && arr[j]%2==0)
{c=arr[i];
arr[i]=arr[j];
arr[j]=c;}
for(int i=0;i<n-1;i++)
for(int j=i+1;j<n;j++)
if(arr[i]<arr[j] && arr[i]%2!=0 && arr[j]%2!=0)
{c=arr[i];
arr[i]=arr[j];
arr[j]=c;}
cout<<"Array"<<endl;
for(int i=0;i<n;i++)
cout<<arr[i]<<" ";
return 0;}
Пример ввода:
2 6 4 1 5 3
Пример вывода:
Array
2 4 6 5 3 1
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота