Game777World
04.03.2020 22:08

Составить программу в pascal, которая вводит строку символов, удаляя все символы, не являющиеся латинскими буквами и затем выводит результаты.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Georgii1998
04.10.2020 01:53
//PascalABC.NET 3.2 сборка 1318

var
  s: string;
  i,k: integer;

begin
  readln(s);
  i:=1;
  k:=length(s);
  while i<>k do
  begin
    k:=length(s);
    if (upcase(s[i]) < 'A') or (upcase(s[i]) > 'Z') then
      begin
        delete(s, i, 1);
        i:=i-1;
      end;
    i:=i+1;
  end;
  writeln(s);
end.

Пример ввода:
Gleb1Kosyrev Sample Текст, Pointer Symbol is ^
Пример вывода:
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота