Войти
Регистрация
Спроси ai-bota
TurboDan
15.01.2020 12:43
Надо в одномерном массиве элементы которого целые числа вставить новый элемент перед первым отрицательным элементом
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Anonimshik33
28.05.2022 17:32
Составить блок-схему, соответствующую фрагменту программы...
Сельга7
24.04.2020 03:45
Высказывания А, В, С истинны для точек, принадлежащих кругу, треугольнику и прямоугольнику соответственно. Для всех точек выделенной на рисунке области истинно высказывание...
linnik4Platon
01.04.2022 15:15
Решите необходимо как можно скорее. даю за корректный ответ....
195920
03.02.2020 19:32
Перевести код из паскаля на Python var y,i:integer; x,j:char; a:array[1..8, a .. h ] of char; begin readln(x); readln(y); for i:=1 to 8 do for j:= a to h do if abs(i-y)*abs(ord(j)-ord(x))=2...
lonelyofiory
21.10.2021 08:48
1) В некоторой стране автомобильный номер длиной 7 символов составляется из заглавных букв (всего используется 22 буквы) и десятичных цифр в любом порядке. Каждый...
kostiusikao
06.04.2022 06:11
1. Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями: F(1) = 2; F(2) = 4 F(n) = 7·F(n - 2) -4·(n - 1), при n 2....
alti1997
21.06.2022 07:52
Опишите универсальную функцию MaxNum(A, N) целого типа, находящую номер максимального элемента вещественного массива А размером N. Поместите функцию в модуль. Разработайте...
Sergey15211
28.06.2021 20:26
1) разработайте программу,запрашивающую у пользователя длины обеих катетов прямоугольного треугольника,и выводящую на экран гипотезу по формуле пифагора 2)запросите...
bandygan666
07.09.2020 21:44
Информационный объем текста,подготовленного с компьютера, равен 3,5 кб. сколько символов содержит этот текст?...
Алена173
15.01.2022 21:50
Надо.файл видеоклипа занимает 145 мбайт.сколько полных клипов вместится на флешку 4 гбайт...
Ответ:
Darina1110
02.08.2020 08:59
//Dev-C++ (C)
#include <stdio.h>
#define n 5
int main(void)
{int Array[n],NewEle,point,boo;
point=-1;
boo=1;
for(int i=0;i<n-1;i++)
{scanf("%d",&Array[i]);
if((Array[i]<0)&&(boo)){
point=i;
boo=0;}
}
if(point==-1) printf("No negative elements");
else
{scanf("%d",&NewEle);
for(int i=n-2;i>=point;i--)
Array[i+1]=Array[i];
Array[point]=NewEle;
for(int i=0;i<n;i++)
printf("%d ",Array[i]);}
return 0;}
Пример ввода:
1
-2
3
4
5
Пример вывода:
1 5 -2 3 4
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота