lizabatyshkina
11.01.2022 06:54

Написать программу в си++. такая : если сумма трёх попарно различных действительных чисел x,y,z меньше единицы, то наименьшее из этих трёх чисел заменить полусуммой двух других; в противном случае заменить меньшее из x и y полусуммой двух оставшихся значений. заранее ))

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
viktoriytamaza
04.10.2020 00:38
//Dev-C++ 5.11

#include <iostream>
using namespace std;

int main(void)
 {float x,y,z=0;
 cin>>x>>y>>z;
 if(x+y+z<1)
  {float min=x;
  if (min>y) min=y;
  if (min>z) min=z;
  if (min==x) x=(y+z)/2;
  if (min==y) y=(x+z)/2;
  if (min==z) z=(x+y)/2;}
  else
  if(x>y) y=(x+z)/2; else x=(y+z)/2;
 cout<<x<<" "<<y<<" "<<z<<" ";
 return 0;}

Пример ввода:
1.1
2.2
3.3
Пример вывода:
2.75 2.2 3.3
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота