vita142
23.09.2021 14:49

Составить программу в паскаль абс и блок-схему: в заданной целочисленной квадратной матрице заменить нулями минимальные элементы каждой строки

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Maks2222222222
03.10.2020 23:47
//PascalABC.NET 3.2 сборка 1318

Const
 n=3;
 m=2;

Var
  ma:array[1..n,1..m] of integer;
  i,j,min:integer;
begin
for i:=1 to n do
begin
min:=integer.MaxValue;
  for j:=1 to m do
    begin
      readln(ma[i,j]);
      if ma[i,j]<min then min:=ma[i,j];
    end;
  for j:=1 to m do
    if ma[i,j]=min then ma[i,j]:=0;
end;
writeln('Final matrix:');
for i:=1 to n do
begin
  for j:=1 to m do
    write(ma[i,j]:4);
writeln;
end;
end.
Составить программу в паскаль абс и блок-схему: в заданной целочисленной квадратной матрице заменить
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота