support38
26.08.2022 09:43

4! +a! -10 a-целое число ,найти факториал ,составить программу паскаль

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bushukova16bk
03.10.2020 23:45
//PascalABC.NET 3.2 сборка 1318

Var
  a:integer;

function fact(a:integer):integer;
  begin
    if a=0 then fact:=1 else fact:=fact(a-1)*a;
  end;

begin
  readln(a);
  writeln(fact(4)+fact(a)+10);
end.

Пример ввода:
4
Пример вывода:
58
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота