vindi1
07.08.2020 21:52

Составить программу на pascal для решения : по трем наборам коэффициентов вычислить корни трех квадратных уравнений.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
levkamorkovka
30.01.2023 05:23

1.Файл — именованная область данных на носителе информации.

Работа с файлами реализуется средствами операционных систем. Многие операционные системы приравнивают к файлам и обрабатывают сходным образом и другие ресурсы.

2.В ОС Windows в имени файла запрещено использование следующих символов: \, /, :, *, ?, ", <, >, |. В Linux эти символы, кроме /, допустимы, хотя использовать их следует с осторожностью, так как некоторые из них могут иметь специальный смысл, а также из соображений совместимости с другими ОС.

3.Txt - блокнот, notepad, TeX

doc - word, openoffice

bmp - photoshop, picaso

rtf - word, openoffice

arj - winrar

4.Флешка

Лазерный диск

Жесткий диск

Любое устройство, подключаемое через USB, с наличием флеш-памяти

5.Каталог — каталог, директория, справочник, папка — объект в файловой системе, упрощающий организацию файлов. Ранее часто использовалось слово директория, которое представляет собой транслитерацию с английского (англ. directory). Типичная файловая система содержит большое количество файлов, и каталоги упорядочить её путём их группировки. Каталог может быть реализован как специальный файл, где регистрируется информация о других файлах и каталогах на носителе информации

6.Файлы могут быть организованы в виде линейной или иерархической файловой структуры

7.Графическое изображение иерархической файловой структуры называется деревом.

8.Путь от диска С:// до самого файла. Например, файл ДОКЛАД.png расположен в папках ШКОЛА, ИСТОРИЯ и на диске С://, тогда его полное имя будет выглядеть так:

С://ШКОЛА/ИСТОРИЯ/ДОКЛАД.png

9.Создание, Открытие, Просмотр,  Редактирование, Сохранение, Удаление

Вырезать, Копировать, Вставить, Переместить, Переименовать

10.1) линуксы - пох,

шиндошс - только читабельные символы кроме :,* и ещё вагон включая целые названия типа con, prn

2) линуксы - расширения чтобы пользователю было понятно что за файл, то есть самой системе расширение не важно. здесь не совсем уместно понятие неполного имени файла

винда - по расширению определяется тип файла, то есть чтобы запустить приложение можно напейсать имя файла приложения без расширения

11.Если он только спускался и поднимался, а начальный уровень D:\ - это понятно, тогда это:

2) D:\SCHOOL\CLASS\LESSONS. -  то есть, это его начальное место нахождения, откуда он опустился в D:\, ну и дальше поднимался в другой каталог.

12.-

13.A:\TOM3\Doc3

15.заменяет один любой символ, * - любое количество любых символов (в том числе и отсутствие символов).

1) bar.txt - нет символа перед b, не подходит

2) obar.txt - подходит

3) obar.xt - нет символа перед x, не подходит

4) barr.txt - нет символа перед b, не подходит

ответ. 2) obar.txt

16.Биология: клетка- ткань-орган-организм, география: улица-город-область-страна, история: год- век-эпоха.

Объяснение:

0,0(0 оценок)
Ответ:
Kember
02.11.2022 02:53
//Описание добавить не вышло на сайт, посему - в файле

#include "stdafx.h"
#include <conio.h>

void swap(short &a, short &b) {
    short c = a;
    a = b;

    b = c;
}

void sort(short &a, short &b, short &c)
{
    short min = a,
        max = c;
    if (min > b) min = b;
    if (min > c) min = c;
    if (max < a) max = a;
    if (max < b) max = b;
    b = a + b + c - min - max;
    a = min;
    c = max;
}

int main()
{
    short a1, b1, c1, a2, b2, c2;
    scanf_s("%hd %hd %hd", &a1, &b1, &c1);
    scanf_s("%hd %hd %hd", &a2, &b2, &c2);

    sort(a1, b1, c1);
    sort(a2, b2, c2);

    if ((a1 == a2) && (b1 == b2) && (c1 == c2))
        printf("Boxes are equal");
    else
        if ((a1 <= a2) && (b1 <= b2) && (c1 <= c2))
            printf_s("The first box is smaller than the second one");
        else
            if ((a2 <= a1) && (b2 <= b1) && (c2 <= c1))
                printf_s("The first box is larger than the second one");
            else
                printf_s("Boxes are incomparable");

    _getch();
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота