ПростоФедя
15.12.2022 01:44

Составить программу паскаль в заданной строке подсчитать количество цифр

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Tasher3tapora
07.01.2023 04:59
Var
  A, B: array [1 .. 6, 1 .. 6] of byte;
  C, D: array [1 .. 6] of byte;
  M: array [1 .. 12] of byte;
  i, j, MIN, MAX, evenCountC, evenCountD: byte;

begin
  randomize;
  for j := 1 to 6 do
  begin
    MAX := 0; MIN := 100;
    evenCountC := 0; evenCountD := 0;
    for i := 1 to 5 do
    begin
      A[i, j] := random(20);
      B[i, j] := random(20);
      if A[i, j] > MAX then MAX := A[i, j];
      if B[i, j] < MIN then MIN := B[i, j];
    end;
    C[j] := MAX;
    D[j] := MIN;
  end;
  writeln('      ***Матрица A***');
  for i := 1 to 5 do
  begin
    for j := 1 to 6 do write(A[i, j]:4);
    writeln;
  end;
  writeln;
  writeln('      ***Матрица B***');
  for i := 1 to 5 do
  begin
    for j := 1 to 6 do write(B[i, j]:4);
    writeln;
  end;
  writeln;
  writeln('***Вектор C***');
  for i := 1 to 6 do
  begin
    writeln(C[i]:7);
    if C[i] mod 2 = 0 then evenCountC := evenCountC + 1;
  end;
  writeln('Количество четных элементов в векторе C = ', evenCountC);
  writeln;
  writeln('***Вектор D***');
  for i := 1 to 6 do
  begin
    writeln(D[i]:7);
    if D[i] mod 2 = 0 then evenCountD := evenCountD + 1;
  end;
  writeln('Количество четных элементов в векторе D = ', evenCountD);
  if evenCountC > evenCountD then
  begin
    writeln('Добавляем вектор C к матрице A.');
    for i := 1 to 6 do A[6, i] := C[i];
    writeln('  ***Измененная матрица A***');
    for i := 1 to 6 do
    begin
      for j := 1 to 6 do write(A[i, j]:4);
      writeln;
    end;
  end
  else
  begin
    writeln('Объединяем два вектора C и D.');
    writeln('Новый вектор M');
    for i := 1 to 6 do M[i] := C[i];
    for i := 7 to 12 do M[i] := D[i - 6];
    for i := 1 to 12 do writeln(M[i]:7);
  end;
  readln;
end.

12. даны матрицы а(5,6) и в(5,6). из максимальных элементов столбцов матрицы а сформировать вектор с
12. даны матрицы а(5,6) и в(5,6). из максимальных элементов столбцов матрицы а сформировать вектор с
0,0(0 оценок)
Ответ:
sayhun
17.12.2022 02:38

5 Run Length Limited — RLL.

На сегодняшний день одни из самых популярных методов является кодирование информации с ограничением длины поля записи. Благодаря этому на диске можно разместить в полтора раза больше данных, нежели в процессе записи по методу MFM. Используя этот метод происходит кодирование не отдельного бита, а целой группы.

6 синхронизация -В процессе работы с цифровой информацией особенное значение получает синхронизация. В момент считывания либо записи информации немаловажным остается точное определение времени каждой смены знака. Если синхронизации нет, то период смены знака может определяться неправильно. В итоге этого неизбежной будет потеря или искажение данных.


кодировки информирования с примерами.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота