Bandit009
23.07.2022 10:58

Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности чисел. ниже представлен вид экрана во время работы программы: вводите последовательно числа. для завершения ввода введите ноль. 1 число: 33 2 число: 45 3 число: -10 4 число: 0 максимальное число: 45

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
123654789e
03.10.2020 20:57
Vari, max, y: integer;
begin
Writeln('Вводите последовательно числа.');
Writeln('Для завершения ввода введите ноль.');
Writeln('');
max := 0;
y := 0;
repeat
y := y + 1;
write(y, ' число:');
readln(i);
if (y = 1) then max := i;
if (i = 0) then break;
if (i > max) then max := i;
until i = 0;
Writeln('');
Writeln('Максимальное число: ', max);
Writeln();
end.
0,0(0 оценок)
Ответ:
Dana1913
03.10.2020 20:57
ОТДЕЛ Задание+;
ИСПОЛЬЗУЕТ Приём, Вывод ИЗ "...\Отделы\Обмен\";

ПЕР
  текЧисло, макс, сч: ЦЕЛ;

УКАЗ
  сч := 1;
  Вывод.Цепь("Вводите последовательно числа.^");
  Вывод.Цепь("Для завершения ввода введите ноль.^");
  Вывод.Цепь("");
  ПОВТОРЯТЬ
    Вывод.ЧЦел("^%d число: ", сч, 0, 0, 0);
    текЧисло := Приём.Число();
    ЕСЛИ текЧисло > макс ТО макс := текЧисло КОН;
    УВЕЛИЧИТЬ(сч)
  ДО текЧисло = 0;
  Вывод.Цепь("^");
  Вывод.ЧЦел("^Максимальное число: %d", макс, 0, 0, 0)

КОН Задание.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота