aigulzhan
08.05.2020 15:09

Напишите программу для решения определить является ли данное число n чётным двухзначным числом

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Yulasha22
03.10.2020 20:47
Var
    n: integer;

begin
    readln(n);
    writeln((n mod 2 = 0) and (n div 10 > 0) and (n div 100 = 0));
end.
0,0(0 оценок)
Ответ:
zhumanovAblai
03.10.2020 20:47
Var
     n,
     check_n,
     : integer;
     flag : boolean;
Begin
     write('Введите чило');
     readln(n);
   
{Проверяется, является ли n четным}
     if n mod 2 = 0
          then
               flag = true;
          else
               flag = false;
     
{Проверяется, является ли n двухзначным}
     if n div 10 <> 0
          then
               flag = true;
          else
               flag = false;

     if flag
          then
                writeln('Число ', n, ' является четным двухзначным');
          else
               writeln('Число ', n, ' не является четным двухзначным');
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота