Vania161
01.11.2021 04:05

Сложное по информатике: нужно написать программу на паскале, не используя if, then, else, с таким результатом: введите число если число четное, то вывести 10; если нечетное, то вывести -10

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Motcic
03.10.2020 20:44
Var a:integer;
begin
write('a = ');
readln(a);
writeln(-20*(abs(a) mod 2)+10);
end.

Пример:
a = 28
10
0,0(0 оценок)
Ответ:
ModerBlet
03.10.2020 20:44
Var
n: integer;
res: boolean;
begin
readln(n);
res:=odd(n);
case res of
true: writeln('-10');
false: writeln('10');
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота