Войти
Регистрация
Спроси ai-bota
djiner
23.02.2023 19:55
Как написать программу в паскале, чтобы 2 рандомных числа не повторялось?
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
IdzSen
19.06.2022 12:26
Row is the horizontal cells in a spreadsheet represented by...
Клевер21
25.03.2021 01:53
Вставьте подходящие слова в пропуски () (вторая часть) Магистрально-модульной архитектурой компьютера называется архитектура компьютера, в которой используется () шина. Она включает...
asssssw
10.09.2021 14:23
Томенде келтірілген тізімнен кіріктелген функцияларды белгілеңіздер...
додо7
13.03.2023 19:59
1)Сколько жителей в самом крупном по численности населения городе Египта? ответ на этот вопрос дайте в тыс.чел 2)Сколько городов Египта имеют жителей больше, чем средняя численность...
AlexSubbotin11
25.05.2021 08:46
Найти произведение нечётных чисел от 1 до 10...
sodel28
31.03.2023 15:24
1) Простейшая инструкция для компьютера. 2) Линия связи для обмена данными между несколькими устройствами. 3) Материал, используемый для хранения данных. 4) Действие компьютера,...
БезумныйКами666
14.04.2022 09:12
3. Что такое блок? а) 7 символов, выделенных в тексте; б) выделенная часть текста; в) 7 строк, выделенных в тексте; г) 7 абзацев, выделенных в тексте....
zdjby1
14.11.2021 10:25
У одного робота с планеты Железяка на складе имелись запасные лампочки в количестве 21 штук. Для планеты он пожертвовал в специальный фонд 12 лампочек, оставив себе на личные нужды...
Santastiff666
21.10.2022 18:03
1. чему равен арифметический порядок числа в десятичной системе счисления, если его внутреннее представление в формате с плавающей точкой – 45е18000?...
elenasamsonova1
21.10.2022 18:03
Написать программу паскаль - вывести на экран элементы , которые больше значения элемента, номер которого введен с клавиатуры...
Ответ:
samsonovich12S1
30.09.2020 07:39
Var a,b,n:integer;
begin
n:=10;
Randomize;
a:=random(n)+1;
b:=random(n)+1;
while b=a do b:=random(n)+1;
writeln('a = ',a,' b = ',b);
end.
Пример:
a = 8 b = 4
0,0
(0 оценок)
Ответ:
Маруся203
30.09.2020 07:39
{
Думаю, это должно работать
Важно, что во второй раз выбор происходит уже среди n-1 вариантов
}
const n = 10;
var i,j: integer;
begin
i := 1 + random(n);
j := 1 + random(n-1);
if j >= i then j := j + 1;
write(i,' ',j)
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота