дашикмашикпык
13.02.2023 03:40

:вы ввели трехзначное число. составьте программу, определяющую, есть ли в этом числе, четные цифры. вопрос: в какой программе решается данная и каким образом?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ksenia5051
30.09.2020 04:21
Лучше всего сделать в pascal. 
Попробуй этот код:
var  n: integer;  boo: boolean;begin  write('Введите число: ');  readln(n);  boo:=odd(n);  case boo of     true: writeln('Нечетное');    false: writeln('Четное');  end;  readln;end.
0,0(0 оценок)
Ответ:
egoyan222
30.09.2020 04:21
Program OddNumeric;
var
  n, i: integer;
  a: array [1..3] of byte;
  b: boolean;
begin
  Write('Введите трехзначное число: ');
  Readln(n);
  a[1]:=n div 100; {1 цифра сотен}
  a[2]:=(n div 10) mod 10; {2 цифра десятков}
  a[3]:=n mod 10; {3 цифра количество единиц}
  b:=false;
  for i:=1 to 3 do
  begin
     if (a[i] mod 2)=0 then
         b:=true;
  end;
  if b then
   Writeln('В этом числе есть четные цифры')
  else
     Writeln('В этом числе нет четных цифр');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота