андрейиванович
02.06.2021 05:37

Составьте программу в результате выполнения которой выясняется входят ли четные цифры в запись данного трехзначного числа. для паскаля

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
мадина523
30.09.2020 03:54
Var a,a1,a2,a3:integer;
begin
write('a = ');
readln(a);
a1:=a div 100;
a2:=a div 10 mod 10;
a3:=a mod 10;
if (a1 mod 2 = 0)or(a2 mod 2 = 0)or(a3 mod 2 = 0)
 then writeln('В числе есть четные цифры')
 else writeln('В числе нет четных цифр');
end.

Пример:
a = 519
В числе нет четных цифр
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота