Vadosik228
31.05.2020 15:52

Иснова я, и снова мой любимый паскаль.. дан массив, состоящий из целых чисел. напишите программу, которая подсчитывает количество положительных чисел среди элементов массива. входные данные сначала задано число n — количество элементов в массиве (1 выходные данные необходимо единственное число - количество положительных элементов в массиве. написал: program u1; var i,n,k: longint; a: array[1..10000] of longint; begin readln(n); for i: =1 to n do readln (a[i]); for i: = 1 to n do write( 'a[i]=',a[i],' '); writeln; for i: = 1 to n do begin if a[i]> 0 then k: =k+1; end; writeln(k); end. но тем не менее, решено не правильно. , посмотрите.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Coova
29.09.2020 01:07
Program qq;
var col, out, i: integer;
arr: array[1..100] of integer;
begin
write('Количество элементов: ');
readln(col);
write('Введите числа: ');
out := 0;
for i := 1 to col do readln(arr[i]);
writeln;
write('Положительных чисел: ');
for i := 1 to col do begin
if(arr[i] > 0) then out := out + 1;
end;
write(out);
end.
-----
В вашем же решении вы не указали переменную k, т.е. у вас нет k := 0; и после выполнения условия if не нужно писать end;
Иснова я, и снова мой любимый паскаль.. дан массив, состоящий из целых чисел. напишите программу, ко
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота