Const n=30; var a : array[1..n] of integer; sum,i : integer; begin Randomize; for i:=1 to n do begin a[i]:=random(20)+10; write(a[i],' '); end; writeln; sum:=0; for i:=1 to n do sum:=sum+a[i]; writeln('Среднемесячная температура = ',sum/n); end.
Пример (для n=10): 15 22 27 20 23 13 23 25 29 26 Среднемесячная температура = 22.3
В задании не сказано, откуда берутся исходные данные, поэтому будем вводить их с клавиатуры. Сначала ведем общее количество данных (не факт, что данные за месяц снимались строго ежедневно), а затем сами данные. Это позволит заодно осуществить контроль ввода.
var n,s,t,i:integer; begin Write('Укажите количество данных: '); Read(n); Writeln('Теперь вводите данные'); s:=0; for i:=1 to n do begin Read(t); s:=s+t end; Writeln('Средняя температура за месяц составила ',s/n:0:1) end.
Пример решения
Укажите количество данных: 11 Теперь вводите данные 27 29 26 31 24 23 27 30 31 28 25 Средняя температура за месяц составила 27.4
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку