zool29
21.05.2020 04:16

C++ циклы. добрый день. нужно написать программу с использованием 3-х циклов. (for, while, while-do) не понимаю в этом, надеюсь вы мне . , . времени до сдачи немного.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
122344566
08.03.2021 16:59

Объяснение:

Заменяем каждый разряд на код из таблицы.

Двоичная СС Восьмеричная СС

000                                    0

001                                     1

010                                     2

011                                     3

100                                     4

101                                     5

110                                     6

111                                     7

Получаем числа:

1024757520 (7) = 001000010100111101111101010000 (2)

1232400565 (7) = 001010011010100000000101110101 (2)

Складываем (0 в начале числа можно убрать):

1000010100111101111101010000 + 1010011010100000000101110101 = 10010101111011110000011000101

Меняем 1 на 0, 0 на  1:

10010101111011110000011000101 = 01101010000100001111100111010

Двоичная СС Шестнадцатеричная СС

0000                               0

0001                               1

0010                               2

0011                               3

0100                               4

0101                               5

0110                               6

0111                                       7

1000                               8

1001                               9

1010                               A

1011                                       B

1100                               C

1101                                       D

1110                                       E

1111                                       F

Получаем число:

1101 0100 0010 0001 1111 0011 1010 (2) = D421F3A (16)

0,0(0 оценок)
Ответ:
Litegran
17.07.2021 03:39

Відповідь:

#include <iostream>

#include <cstdlib>

#include <time.h>

using namespace std;

void randArray(int *Array, int size){

for(int i = 0; i < size; i++){

 Array[i] = rand() % 10 + 1;

}

}

void printArray(int *Array, int size){

for(int i = 0; i < size; i++){

 cout << Array[i] << " ";

}

}

int sumelements(int *Array, int size){

int S = 0;

for(int i = 0; i < size; i++){

 S += Array[i];

}

return S;

}

int main(){

srand(time(NULL));

setlocale(LC_ALL , "Rus");

int size;

cout << "Введите кол-во елементов массива: ";

cin >> size;

if(size < 0){

 cout << "Количество не может быть меньше 0" << endl;

}

int *Array = new int[size];

randArray(Array,size);

printArray(Array,size);

cout << "\nСумма всех елементов массива = " << sumelements(Array,size) << endl;

delete [] Array;

return 0;

}

Пояснення:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота