akerkebaidylda
09.04.2020 04:44

Составить программу на free pascal. дано натуральное число. верно ли, что произведение его цифр не больше 50

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Картофан7777777
08.09.2020 01:35
Если число не слишком большое, то:
var n,p:integer;
begin
write('n = ');
readln(n);
p:=1;
while n>0 do
 begin
 p:=p*(n mod 10);
 n:=n div 10;
 end;
if p<=50
 then writeln('Произведение цифр числа = ',p,' (<= 50)')
 else writeln('Произведение цифр числа = ',p,' (> 50)');
end.

Пример:
n = 456
Произведение цифр числа = 120 (> 50)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота