BanderSap
08.07.2021 13:13

Пож 1 составить программу, которая бы запрашивала хнач , хкон , шаг c и определяла сумму всех отрицательных чисел от хнач до хкон с шагом с (решить , используя цикл с предусло-вием – while .. do).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
aluanakim
28.09.2020 19:16
Var
  x0, x1, c, sum: integer;
begin
  sum:=0;
  readln(x0, x1, c);
  while x0<=x1 do
  begin
    sum:=sum+x0;
    x0:=x0+c;
  end;
  writeln(sum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота