Напишите программу которая находит максимальный и минимальный из чётных пложителных элементов массива. если в массиве нет чётных положительных элементов, нужно вывести сообщение об этом. по информатика с ответам
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016 begin var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println; var b:=a.Where(x->(x>0) and x.IsEven); if b.Count=0 then Writeln('Нет четных положительных элементов') else Writeln('Min=',b.Min,', max=',b.Max) end.
//"Школьный" вариант //Pascal ABC.NET 3.1 сборка 1256
Const n=10;
Var ar:array[1..n] of integer; i,max,min:integer; b:boolean; begin randomize; b:=false; max:=integer.MinValue; min:=integer.MaxValue; writeln('Array:'); for i:=1 to n do begin ar[i]:=random(-100,100); if (ar[i]>max) and not(odd(ar[i])) and (ar[i]>0) then begin max:=ar[i]; b:=true; end; if (ar[i]<min) and not(odd(ar[i])) and (ar[i]>0) then begin min:=ar[i]; b:=true; end; write(ar[i]:4); end; writeln; if b=false then writeln('Нет удовлетворяющих условиям чисел') else begin writeln('Max=',max); writeln('Min=',min); end; end.
Пример работы программы: Array: 98 60 -41 -88 63 -81 -77 -96 -18 51 Max=98 Min=60
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку