ммрк
20.08.2020 11:33

Задан массив y с количеством элементов n. сформируйте массив, в котором элементы с четными индексами будут равны соответствующим элементам исходного массива, а элементы с нечетными индексами будут равны 0. надо. написать программу на языке паскаль*(

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
erparsian2017
03.10.2020 18:44
Const n=10;
var y,z:array[1..n] of integer;
i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 y[i]:=random(51);
 write(y[i]:4);
 end;
writeln;
writeln('Полученный массив:');
for i:=1 to n do
 if i mod 2 = 0 then z[i]:=y[i] else z[i]:=0;
for i:=1 to n do write(z[i]:4);
writeln;
end.

Пример:
Исходный массив:
  16  22  48  16   9  33  27  42  40  24
Полученный массив:
   0  22   0  16   0  33   0  42   0  24
0,0(0 оценок)
Ответ:
Chemist2001
03.10.2020 18:44
//Индексация с 0
//Pascal ABC.NET 3.1 сборка 1256

Const n=10;
Var
 i:integer;
 ar2:array[0..n-1] of integer;
begin
 var ar:=ArrRandomInteger(n,-10,10);
 writeln('Array Y:');
 ar.Println;
 for i:=0 to n-1 do
 ar2[i]:=0;
 for i:=0 to n-1 do
 if not(odd(i)) then ar2[i]:=ar[i];
 writeln('Final array:');
 ar2.Println;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота