Составить программу, нахождение степени числа, используя подпрограмму (функцию нахождения степени).программа должна облодать интерфейсом (на паскале с описаниями)
//Вариант с нормальным интерфейсом uses system,system.Windows.Forms;
Var myForm:Form; myButton:Button; myTextBox1:TextBox; myTextBox2:TextBox; myTextBoxRez:TextBox;
procedure MyButtonClick(sender:Object;e:EventArgs); Var i,ar,a,b:integer; begin a:=strtoint(myTextBox1.text); b:=strtoint(myTextBox2.text); ar:=1; for i:=1 to b do ar:=ar*a; myTextBoxRez.Text:=ar.ToString; end; begin myForm:=new Form; //создание объекта - формы myform.Left:=500; myform.top:=500; myform.AutoSize:=true; myform.Width:=300; myform.Height:=100; myTextBox1:=new TextBox; //создание объекта - текстового поля для числа myTextBox1.Left:=80; myTextBox1.Top:=40; myTextBox1.Enabled:=true; myTextBox1.Width:=105; myTextBox1.Height:=100; myTextBox1.MaxLength:=16; myTextBox1.ReadOnly:=false; myTextBox1.Visible:=true; myTextBox2:=new TextBox; //создание объекта - текстового поля для степени myTextBox2.Left:=80; myTextBox2.Top:=80; myTextBox2.Enabled:=true; myTextBox2.Width:=105; myTextBox2.Height:=100; myTextBox2.MaxLength:=16; myTextBox2.ReadOnly:=false; myTextBox2.Visible:=true; myTextBoxRez:=new TextBox; //создание объекта - текстового поля для результата myTextBoxRez.Left:=80; myTextBoxRez.Top:=120; myTextBoxRez.Enabled:=true; myTextBoxRez.Width:=105; myTextBoxRez.Height:=100; myTextBoxRez.MaxLength:=16; myTextBoxRez.ReadOnly:=true; myTextBoxRez.Visible:=true; myButton:=new Button; //создание объекта - кнопки myButton.Text:='^'; myButton.Left:=80; myButton.top:=160; myButton.AutoSize:=true; myForm.Controls.Add(myTextBox1); myForm.Controls.Add(myTextBox2); myForm.Controls.Add(myTextBoxRez); myForm.Controls.Add(myButton); myButton.click+=MyButtonClick; Application.Run(myForm); end.
//Вариант с CRT Uses Crt;
Var a,b:integer;
function fpow(a,b:integer):integer; Var rez,i:integer; begin rez:=1; //чтобы не было 0 for i:=1 to b do //умножаем rez на a b раз чтобы получить нужную степень rez:=rez*a; fpow:=rez; end;
begin clrscr; Write('Введите число:'); readln(a); write('Введите требуемую степень числа:'); readln(b); writeln('Результат:',fpow(a,b)); end.
Пример ввода: 2 10 Пример вывода: 1024
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку