Составить программу на паскале. даны стороны двух треугольников. найти сумму их периметров и сумму площадей. определить процедуру для расчета периметра и площади треугольника по его сторонам
procedure PerAndPlo(var s,p:real;a,b,c:real); Var pp:real; begin p:=a+b+c; pp:=p/2; s:=sqrt(pp*(pp-a)*(pp-b)*(pp-c)); end;
Var a1,b1,c1,p1,s1,a2,b2,c2,p2,s2:real; begin Writeln('Введите длины сторон первого треугольника:'); readln(a1,b1,c1); Writeln('Введите длины сторон второго треугольника:'); readln(a2,b2,c2); PerAndPlo(s1,p1,a1,b1,c1); PerAndPlo(s2,p2,a2,b2,c2); Writeln('Сумма периметров:',(p1+p2)); Writeln('Сумма площадей:',(s1+s2)); end.
Пример ввода: 1 2 3 4 5 6 Пример вывода: Сумма периметров:21 Сумма площадей:9.92156741649221