artemlis1302200
21.05.2021 19:25

Написать программу в с++ составить программу для выполнения указанного ниже ,используя оператор множественного ветвления. по номеру класса выдать название школьной ступени.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Данил12437
03.10.2020 18:42
//Pascal ABC.NET 3.1 сборка 1219

Var
 a:integer;
begin
readln(a);
case a of
1..4:writeln('Младшая школа');
5..9:writeln('Средняя школа');
10..11:writeln('Старшая школа')
else writeln('Не класс');
end;
end.

//Dev-C++ 4.9.9.2

#include <iostream>
using namespace std;

int main(){
    setlocale(LC_CTYPE,"Russian");
    int a=0;
    cin>>a;
    switch(a){
              case 1:
              case 2:
              case 3:
              case 4:
                   cout<<"Младшая школа";
                   break;
              case 5:
              case 6:
              case 7:
              case 8:
              case 9:
                   cout<<"Средняя школа";
                   break;
              case 10:
              case 11:
                   cout<<"Старшая школа"; 
                  break;
              default:
                      cout<<"Не класс";
              break;
}
    cin.get();
    cin.get();
    return 0;
}

Пример ввода:
11
Пример вывода:
Старшая школа
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота