tutinae
16.06.2021 09:33

Перевод времени из минут и секунд в секунды. написать программу, которая запрашивает у пользователя время в виде «минуты – секунды», после чего вычисляет полное число секунд во введенном значении и выводит результат вычисления на экран. при составлении программы учесть, что число минут во вводимом значении – неотрицательно. учесть ситуацию с переполнением. примечание: предполагается использование в вещественных чисел. программа должна выявлять и корректно реагировать на другие исключительные ситуации (например, деление на ноль и ситуацию переполнения).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
svitlanakost
03.10.2020 18:38
//Pascal ABC.NET 3.1 сборка 1219

Var
 m,s,r:double;
begin
try
read(m,s);
r:=s+m*60;
writeln(r);
except
 on System.OverflowException do writeln('Переполнение');
end;
end.

Пример ввода:
32345678903456787654324657865432456786543245687654356786543
3456754365786545678976543567865435678
Пример вывода:
1.94074073420741E+60
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота