rimmabuketova
30.03.2021 23:56

Написать программу в паскаль. дан произвольный текст. преобразовать его по следующим правилам: все буквы «о» заменяются на «оа», все пробелы заменяются символом «_», а запятые удаляются.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Zanyt
03.10.2020 18:22
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var s:=ReadlnString('>');
  s:=s.Replace('о','oa').Replace(' ','_').Replace(',','');
  Writeln(s);
end.

Тестовое решение
> "Дает корова молоко" - писать, конечно, не легко!
"Дает_кoaрoaва_мoaлoaкoa"_-_писать_кoaнечнoa_не_легкoa!
0,0(0 оценок)
Ответ:
Xalk22
03.10.2020 18:22
S- переменная текста
i- счетчик
readln(s);
for i:= 1 to length(s) do
 begin
  if (s[i]='о') then
 s[i]:='оа';
    if  (s[i]=' ') then
(s[i]='_')
if (s[i]=',') then
 s[i]:='';
writeln(s);
end.
   Вроде как-то так
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота