teslinovpavel
03.05.2023 00:04

Нужно написать программу в pascal.. даны названия 3 городов (любых). вывести на экран самое длинное и самое короткое название.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
thefizrap0c5s5
07.09.2020 23:27
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:array[1..3] of string;
  var l:array[1..3] of integer;
  for var i:=1 to 3 do begin
    Write('Город ',i,': '); Readln(a[i]);
    l[i]:=Length(a[i])
    end;
  var imin:=1; var imax:=1;
  for var i:=2 to 3 do begin
    if l[i]<l[imin] then imin:=i;
    if l[i]>l[imax] then imax:=i
    end;
  Writeln('Самое длинное название- ',a[imax]);
  Writeln('Самое короткое название- ',a[imin])
end.

Тестовое решение
Город 1: Москва
Город 2: Минск
Город 3: Киев
Самое длинное название- Москва
Самое короткое название- Киев
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота