newaktau
07.04.2022 21:08

Написать программу , которая вводит с клавиатуры число от 0 до 999999(использовать переменные типа longint) и выдает на экран дисплея сумму цифр этого числа. напишите в делфи .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
МаркРешетов
28.09.2020 10:56
Var
    n: longint;
    i, sum: integer;

begin
    Readln(n);
    Sum := 0;
    
    while n > 0 do
    begin
        Sum := sum + (n mod 10);
        n := n div 10;
    end;
    Writeln(sum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота