luizalol
17.06.2021 12:52

Написать программу на паскале. "удалить из массива все отрицательные элементы". не через randomize, .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bigsoldier
25.08.2020 16:36
//Pascal ABC.NET v3.1 сборка 1219

Const
 n=5;

 Var
 ar:array[1..n] of integer;
 i,j,k:integer;
begin
k:=n;
 for i:=1 to n do
  readln(ar[i]);
 i:=1;
 while (i<>n) and (k<>0) do
 begin
  if ar[i]<0 then
  begin
   for j:=i to n-1 do
    ar[j]:=ar[j+1];
   dec(k);
  end
  else inc(i);
 end;
 writeln('Final array:');
 for i:=1 to k do
 write(ar[i]:4);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота