Snowandsand368
06.02.2021 08:59

5-9 информатика написать программу в результате которой на экране появится диалог: - ! я - компьютер! а как тебя зовут? - мария - мария, 3 4 4 - ввод оценок - мария, твой средний по

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kiraн1999
17.06.2020 06:19

ip-адрес это 32 бита (4 байта). маска подсети - тоже 32 бита (4 байта).

ip-адрес можно условно разделить на две части (старшие биты - адрес сети, младшие биты - адрес устройства внутри этой сети). Граница (сколько бит адрес сети, а сколько бит адрес устройства) определяется числом после косой черты. В пунктах 1) и 2) это число 14, то есть под адрес сети отводится 14 бит (значит под адрес устройства: 32-14=18 бит). Чтобы сформировать маску подсети надо записать 32 бита таких чтобы старшие биты (адрес сети) были равны 1, а младшие биты (адрес устройства) были равны 0. Сделаем для случая из п.2 (то есть 14): буду писать группами по 8 бит, чтобы удобней было переводить потом биты в байты.

11111111 11111100 00000000 00000000

если теперь каждый из этих байтов записать в десятичной системе счисления и разделить точками, то получим классическую запись маски подсети (и заодно решение п.2):

255.252.0.0

Теперь насчет емкости (п.1). С такой маской подсети под адрес устройства в этой сети отводится 32-14=18 бит. Значит всего может быть адресов:

Осталось только вспомнить, что адрес где все биты равны нулям используе�ся для обозначения всей подсети, а адрес где все биты равны единицам используется в качестве широковещательного адреса на подсеть. То есть эти два адреса не могут принадлежать ни одному устройству в этой подсети. Получается что всего устройств в подсети (емкость) равна 262144-2=262142. Это ответ на п.1.

С п.3 я не уверен, что правильно понимаю в чём именно во Но насколько понял:

в указанной в задании сети под адрес сети выделено 13 бит, значит под адреса устройств/подсетей 32-13=19 бит.

Маска подсети определяется это количеством бит (причем всегда целым - поэтому разбиение может идти только по целым степеням двойки). Чтобы разбить на 400 подсетей надо под адрес подсети выделить x бит, так чтобы:

нам подходят 9 бит (512 > 400), 10 бит (1024 > 400), 11 бит (2048 > 400) и т. д. В условии есть фраза про максимальную экономию адресного Скорее всего имелось ввиду, чтоб адрес подсети был минимальным. Минимальное из подходящих - это 9 бит.

Итого: в изначальном адресном в условии) адрес сети занимал 13 бит. Адрес подсети (после разбиения на 400 подсетей) "заберёт" ещё 9. Под адреса устройств в каждой подсети остается 32-(13+9)= 10 бит. То есть количество адресов в каждой подсети будет:

Минус два служебных адреса (как и в п.1). Итого 1022 устройства с разными адресами могут быть в каждой из получившихся подсетей

Объяснение:

0,0(0 оценок)
Ответ:
Yarik176
16.12.2021 13:09

В задании исходный код программы введен немного неправильно, поэтому я решил его загуглить и нашел во с идентичными кодом без ответа. Код, вроде, рабочий, но я его серьезно не тестировал.

N = 1E5

a, p, s = [], [], []

def main():

       n = k = i = j = 0

       (n, k) = (int(input()), int(input()))

       p = [0] * n

       s = [0] * n

       for i in range(0, n):

               a.append(int(input()))

               if a[i] > a[j]:

                       p[i] = i

                       j = i

               else:

                       p[i] = p[j]

       

       j = n - 1

       for i in range(n - 1, -1, -1):

               if (a[i] >= a[j]):

                       s[i] = i

                       j = i

               else:

                       s[i] = s[j]

       

       m, l, r = 0, 0, k + 1

       i = l

       for j in range(r, n):

               t = a[p[i]] + a[s[j]]

               if t > m:

                       l = p[i]

                       r = s[j]

                       m = t

               i += 1;

       print(str(l + 1) + " " + str(r + 1))

if __name__ == "__main__":

       main()

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота