Maksim55666
13.06.2022 19:36

Составьте программу, которая в массиве из 15 чисел складывает все элементы, больше 10

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nikastezkaowl9vp
03.10.2020 17:19
Const
    handsfree = true;
    n = 15;

var
    a: array[1..n] of real;
    i: integer;
    sum: real;

begin
    {ввод массива}
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(100) - 50;
            write(a[i], ' ');
        end
        else readln(a[i]);
    end;
    writeln();
    
    {подсчет суммы и произведения}
    sum := 0;
    for i := 1 to n do
    begin
        if a[i] > 10 then
            sum := sum + a[i];
    end;
    writeln('sum = ', sum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота