LORDytGucci
24.05.2020 11:32

Написать программу напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, кратных 3. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число, кратное 3. количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число – сумму чисел, кратных 3.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tim1415320053774
07.08.2020 21:58
Var
n,a,i,s:integer;
begin
readln(n);
s:=0;
for i:=1 to n do
begin
readln(a);
if a mod 3=0 then
s:=s+a;
end;
writeln(s);
end.
0,0(0 оценок)
Ответ:
Kisaaaa111
07.08.2020 21:58
//Pascal ABC.NET 3.1

begin
 var n:=readinteger();
 var ar:=readArrInteger(n);
 writeln(ar.where(x -> x mod 3=0).sum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота