ЮлічкаВдовіна
21.02.2020 23:34

Написать программу для ряда : 1.найти сумму трех чисел. 2.катеты прямоугольного треугольника известны.найти гипотенузу. 3.найти среднеарифметическое двух чисел. 4.найти длину окружности,если известна площадь круга. 5.какой процент составляет число а от числа b. 6.найдите площадь треугольника с формулы герона. 7.найдите площадь кольца,если его толщина i см,диаметр внутри круга d см. 8.вычислите площадь треугольника заданного координатами вершин. 9.вычислить длинны сторон треугольника по заданным координатам его вершин. зарание )

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Рита0Венес
27.09.2020 16:29
Var
    a, b, c, p: real;
    a1, b1, c1: real;
    a2, b2, c2: real;

function SideLength(a1, a2, b1, b2: real): real;
begin
    SideLength := sqrt(sqr(a1 - b1) + sqr(a2 - b2));
end;

begin
    writeln('1.Найти сумму трех чисел');
    readln(a, b, c);
    writeln(a + b + c);
    
    writeln('2.Катеты прямоугольного треугольника известны.Найти гипотенузу.');
    readln(a, b);
    writeln(sqrt(a * a + b * b));
    
    writeln('3.Найти среднеарифметическое двух чисел.');
    readln(a, b);
    writeln((a + b) / 2);
    
    writeln('4.Найти длину окружности,если известна площадь круга.');
    readln(a);
    writeln(sqrt(a / pi) * 2 * pi);
    
    writeln('5.Какой процент составляет число а от числа b.');
    readln(a, b);
    writeln(a / b * 100);
    
    writeln('6.Найдите площадь треугольника с формулы Герона.');
    readln(a, b, c);
    p := (a + b + c) / 2;
    writeln(sqrt((p - a) * (p - b) * (p - c) * p));
    
    writeln('7.Найдите площадь кольца,если его толщина I см,диаметр внутри круга d см.');
    readln(a, b);
    c := a + b;
    writeln(pi * (c * c - b * b));
    
    writeln('8.Вычислите площадь треугольника заданного координатами вершин.');
    readln(a1, a2, b1, b2, c1, c2);
    writeln(((a1 - c1) * (b2 - c2) - (a2 - c2) * (b1 - c1)) / 2);
    
    writeln('9.Вычислить длинны сторон треугольника по заданным координатам его вершин.');
    a := SideLength(a1, a2, b1, b2);
    b := SideLength(c1, c2, b1, b2);
    c := SideLength(a1, a2, c1, c2);
    writeln(a, ' ', b, ' ', c);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота