Erika211
31.01.2023 21:28

Написать программу для pascal. вычислите сумму положительных и кол-во отрицательных чисел на отрезке, концы которого вводятся с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DAVIDUIOP
03.10.2020 16:50
Var a,b,k1,k2,s:integer; 
begin 
s:=0; 
k1:=0; 
writeln('Введите начало и конец отрезка'); 
read(a,b); 
k2:=b-a+1; 
repeat 
if b<0 then break; 
s:=s+b; 
b:=b-1; 
inc(k1); 
until (b=-1) or (b=a-1); 
writeln('Сумма всех целых положительных чисел на отрезке = ',s); 
writeln('Количество отрицательных целых чисел = ', k2-k1); 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота