про739
06.05.2023 23:41

Массив arr[6] заполнен единицами. написать программу, которая используя датчик случайных целых чисел, получает на каждом шаге цикла случайное значение индекса массива х и выполняет операцию arr[x]=0. найти среднее число, при котором все значения элементов массива будут заменены на нули.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
siniTamy
27.09.2020 10:21
Var arr:array [1..6] of integer;i,k,x,s,d,j:integer;beginrandomize;d:=0;for j:=1 to 1000 dobeginfor i:=1 to 6 do  arr[i]:=1;k:=1;s:=1;while k<>0 do begin   x:=random(6)+1;   arr[x]:=0;   if (arr[1]=0) and (arr[2]=0) and (arr[3]=0) and (arr[4]=0) and(arr[5]=0) and (arr[6]=0) then k:=0;   s:=s+1; end;d:=d+s; end;Writeln('В среднем цикл отработал ',d/1000,' раз'); end.
В среднем цикл отработал 15.946 разПри многократном запуске получается около 16 раз
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота