mix42
03.05.2021 16:52

Составить программу решения уравнения (x-a²)×(x+b²)=c² относительно х в pascal abc

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
taniamishanina
09.04.2021 00:15
// PascalABC.NET 3.2, сборка 1382 от 06.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк в массиве:');
  var m:=ReadInteger('Количество столбцов в массиве:');
  Writeln('*** Исходный массив [',n,',',m,'] ***');
  var a:=MatrRandom(n,m,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  var p:=ReadInteger('Номер строки для формирования вектора:');
  var x:=a.Row(p-1); x.Println
end.

Пример:
Количество строк в массиве: 6
Количество столбцов в массиве: 9
*** Исходный массив [6,9] ***
  25 -94  49  38  93   6  76  61 -79
  49  25 -82 -43 -92 -51 -78  62   4
 -31  43 -78 -34  48  19 -17 -26 -98
  82  44 -43  36  82  50 -14  39 -87
  88 -25  12 -94 -96  68   7   9 -28
  96  38 -15 -77 -99 -78 -60 -21  57

Номер строки для формирования вектора: 4
82 44 -43 36 82 50 -14 39 -87
0,0(0 оценок)
Ответ:
tubip888
28.02.2022 21:03
1) Давай с тобой определим, что такое граф, или семантическая сеть. Граф - это когда некоторое количество точек соединено линиями, и линии не всегда есть между каждой парой точек. Графы применяются для изучения какого-либо события, для анализа данных. К примеру, есть станции А, Б, В и Г. Тебе надо с А попасть на станцию Г кратчайшим путём. Чтобы узнать этот самый путь, нужна карта. А схематичная карта такого пути - это и есть граф! (Кстати, карту метро тоже можно назвать очень большим графом).
2) Наметим пункты нашего графа. Какие мы знаем? Например, Облака, Дождь, Снег, Поверхность Земли, Земля, Животные, Растения, Пар.
3) Располагаем их и соединяем стрелочками (движение возможно только в одну сторону) или просто линиями.
Представьте круговорот воды в природе в виде графа (семантической сети), в которой вершинами являютс
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота